Graal Forums  

Go Back   Graal Forums > Development Forums > Tech Support
FAQ Members List Calendar Search Today's Posts Mark Forums Read

Reply
 
Thread Tools Search this Thread Display Modes
  #1  
Old 10-25-2008, 09:31 AM
TSAdmin TSAdmin is offline
Forum Moderator
TSAdmin's Avatar
Join Date: Aug 2006
Location: Australia
Posts: 1,980
TSAdmin is a splendid one to beholdTSAdmin is a splendid one to beholdTSAdmin is a splendid one to beholdTSAdmin is a splendid one to beholdTSAdmin is a splendid one to behold
NDFAPI.DLL Problems

Running OS: Microsoft Windows Vista

Problem:
As you will plainly see from the image attached, I am getting an error when opening files.

When it happens:
This will only ever happen when a LEVEL (.nw) file is downloaded via Double-Clicking the item in the file browser.

What happens:
When opening a level using the "Double-Click in File Browser" method, that error pops up and RC is then terminated upon clicking Okay

Extra:
-> No log file found with error
-> Using the method of downloading the DLL (In this case the missing COMCTL32.DLL file) to the /Graal/ folder as with the MSVCR80.DLL problem does not fix it.

Any suggestions?
Attached Thumbnails
Click image for larger version

Name:	ndfapi.JPG
Views:	111
Size:	60.5 KB
ID:	46315  
__________________
TSAdmin (Forum Moderator)
Welcome to the Official GraalOnline Forums! Where sharing an opinion may be seen as a declaration of war!
------------------------
· User Agreement · Code of Conduct · Forum Rules ·
· Graal Support · Administrative Contacts ·
Reply With Quote
  #2  
Old 10-25-2008, 02:30 PM
Codein Codein is offline
jwd
Codein's Avatar
Join Date: Oct 2005
Location: Greater Manchester
Posts: 2,423
Codein has a spectacular aura aboutCodein has a spectacular aura about
Send a message via AIM to Codein Send a message via MSN to Codein
I also get this problem.
Reply With Quote
  #3  
Old 10-25-2008, 03:19 PM
CharlieM CharlieM is offline
Hired/Fired
Join Date: Sep 2007
Location: Places you dont want to go babe.
Posts: 1,834
CharlieM will become famous soon enough
Send a message via AIM to CharlieM Send a message via MSN to CharlieM
I had the problem once, changed my files around and it fixed the problem,
__________________


"You can discover what your enemy fears most by observing the means he uses to frighten you."

Eric Hoffer

turned that one on you didn't I.
Reply With Quote
  #4  
Old 10-25-2008, 05:57 PM
Inverness Inverness is offline
Incubator
Inverness's Avatar
Join Date: Aug 2004
Location: Houston, Texas
Posts: 3,613
Inverness is a jewel in the roughInverness is a jewel in the rough
The error says that a function is missing in the library, not that the library itself is missing. And when I viewed comctl32.dll I couldn't find function 0x158, so I suppose the ntfapi.dll was built with a different version of the dll.

You people should learn to read error messages

Edit: I found the problem, the comctl32.dll in the system32 folder is version 5.82, only version 6.0 of the file has ordinal 0x158. Find the version 6.0 of the file in the WinSxS folder and copy it to the folder with the RC executable.

The file would be in WinSxS\x86_microsoft.windows.common-controls_6595b64144ccf1df_6.0.6001.18000_none_5cdb aa5a083979cc

And the stupid forum stuck a space in that path automatically near the end.

Edit2: Just stick the attached file into the same folder as the remotecontrol2.exe and rename it to remotecontrol2.exe.manifest
Attached Files
File Type: txt manifest.txt (417 Bytes, 106 views)
__________________

Last edited by Inverness; 10-25-2008 at 06:22 PM..
Reply With Quote
  #5  
Old 10-26-2008, 04:52 AM
TSAdmin TSAdmin is offline
Forum Moderator
TSAdmin's Avatar
Join Date: Aug 2006
Location: Australia
Posts: 1,980
TSAdmin is a splendid one to beholdTSAdmin is a splendid one to beholdTSAdmin is a splendid one to beholdTSAdmin is a splendid one to beholdTSAdmin is a splendid one to behold
Your steps, Inverness, were followed exactly and although the crashing has stopped, there's a new error:

Quote:
L: \Graal things\___.nw
Application not found
Edit: Having randomly deciding to change USB ports it now says "Downloaded file ___.nw" and not actually doing anything after that. The file can be downloaded a hundred times, but no errors, no crashes, just downloads, no GraalEditor opening it, nothing.
__________________
TSAdmin (Forum Moderator)
Welcome to the Official GraalOnline Forums! Where sharing an opinion may be seen as a declaration of war!
------------------------
· User Agreement · Code of Conduct · Forum Rules ·
· Graal Support · Administrative Contacts ·
Reply With Quote
  #6  
Old 10-26-2008, 05:34 AM
Inverness Inverness is offline
Incubator
Inverness's Avatar
Join Date: Aug 2004
Location: Houston, Texas
Posts: 3,613
Inverness is a jewel in the roughInverness is a jewel in the rough
Quote:
Originally Posted by TSAdmin View Post
Your steps, Inverness, were followed exactly and although the crashing has stopped, there's a new error:



Edit: Having randomly deciding to change USB ports it now says "Downloaded file ___.nw" and not actually doing anything after that. The file can be downloaded a hundred times, but no errors, no crashes, just downloads, no GraalEditor opening it, nothing.
The editor executable is on a USB or hard drive? Make sure the association is updated? Make sure you have an appropriate download folder selected.
__________________
Reply With Quote
  #7  
Old 10-26-2008, 05:54 AM
TSAdmin TSAdmin is offline
Forum Moderator
TSAdmin's Avatar
Join Date: Aug 2006
Location: Australia
Posts: 1,980
TSAdmin is a splendid one to beholdTSAdmin is a splendid one to beholdTSAdmin is a splendid one to beholdTSAdmin is a splendid one to beholdTSAdmin is a splendid one to behold
Quote:
Originally Posted by Inverness View Post
The editor executable is on a USB or hard drive? Make sure the association is updated? Make sure you have an appropriate download folder selected.
The download folder is a folder on the USB Drive, and association has been set properly since the day the computer was bought. Was one of the first things done. I have no idea why it's started acting up all the sudden :s
__________________
TSAdmin (Forum Moderator)
Welcome to the Official GraalOnline Forums! Where sharing an opinion may be seen as a declaration of war!
------------------------
· User Agreement · Code of Conduct · Forum Rules ·
· Graal Support · Administrative Contacts ·
Reply With Quote
  #8  
Old 10-26-2008, 05:57 AM
Inverness Inverness is offline
Incubator
Inverness's Avatar
Join Date: Aug 2004
Location: Houston, Texas
Posts: 3,613
Inverness is a jewel in the roughInverness is a jewel in the rough
Quote:
Originally Posted by TSAdmin View Post
The download folder is a folder on the USB Drive, and association has been set properly since the day the computer was bought. Was one of the first things done. I have no idea why it's started acting up all the sudden :s
You know it only opens the editor if you double-click the file, not right-click and hit download, right?
__________________
Reply With Quote
  #9  
Old 10-26-2008, 05:59 AM
TSAdmin TSAdmin is offline
Forum Moderator
TSAdmin's Avatar
Join Date: Aug 2006
Location: Australia
Posts: 1,980
TSAdmin is a splendid one to beholdTSAdmin is a splendid one to beholdTSAdmin is a splendid one to beholdTSAdmin is a splendid one to beholdTSAdmin is a splendid one to behold
Quote:
Originally Posted by Inverness View Post
You know it only opens the editor if you double-click the file, not right-click and hit download, right?
I've been using RC for quite a long time now, I'm pretty sure I have a handle on that concept
__________________
TSAdmin (Forum Moderator)
Welcome to the Official GraalOnline Forums! Where sharing an opinion may be seen as a declaration of war!
------------------------
· User Agreement · Code of Conduct · Forum Rules ·
· Graal Support · Administrative Contacts ·
Reply With Quote
  #10  
Old 10-26-2008, 06:06 AM
Inverness Inverness is offline
Incubator
Inverness's Avatar
Join Date: Aug 2004
Location: Houston, Texas
Posts: 3,613
Inverness is a jewel in the roughInverness is a jewel in the rough
Quote:
Originally Posted by TSAdmin View Post
I've been using RC for quite a long time now, I'm pretty sure I have a handle on that concept
Just making sure the crashing didn't make you forget.

I can't help you without more specific error information. D:

All I can say is to try resetting the file type association.
__________________
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 05:35 PM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2021, vBulletin Solutions Inc.
Copyright (C) 1998-2019 Toonslab All Rights Reserved.