Graal Forums  

Go Back   Graal Forums > Development Forums > Tech Support
FAQ Members List Calendar Search Today's Posts Mark Forums Read

Reply
 
Thread Tools Search this Thread Display Modes
  #1  
Old 12-23-2006, 06:56 PM
Questa Questa is offline
Back to the Beat
Join Date: Jan 2002
Location: USA
Posts: 1,230
Questa is on a distinguished road
Send a message via AIM to Questa
Newest Linux issue

Recently used the installer found on the Graal website to reinstall Graal4 on my Linux box. I couldn't use the auto patching part of the client because it wouldn't run due to X server errors. Now whenever I run Graal, I get a license error. This is my console log:

NPC Code:

//-------------------------- 12/23/2006 -- 10:51:17 -----
Math Init:
Installing Standard C extensions
Installing Assembly extensions
Installing FPU extensions
Installing MMX extensions
Installing SSE extensions
Input Init:
No joysticks found.
Input initialized
Video Init:
OpenGL display device detected.
data directory: /usr/share/graal/

user data directory: /home/dustin/.graal/graal4/

The license file is invalid.


__________________
Reply With Quote
  #2  
Old 12-30-2006, 01:11 AM
Questa Questa is offline
Back to the Beat
Join Date: Jan 2002
Location: USA
Posts: 1,230
Questa is on a distinguished road
Send a message via AIM to Questa
Umm... Stefan, can you fix this error or are you just going to leave it there?
__________________
Reply With Quote
  #3  
Old 12-31-2006, 10:29 AM
ReBorn_Spirit ReBorn_Spirit is offline
Tįri o Taurė
Join Date: Oct 2003
Location: North Dakota, USA
Posts: 1,060
ReBorn_Spirit is on a distinguished road
Exclamation

That Linux installer is horrible. First of all if your Environment isnt configured correctly it will cause errors. One of these common to find is trying to install graal4 onto a 64 bit Redhat based machine. The installer graal4 tries to install is 32 bit and doesn't match up to the FC 4 - 6 programs.

Then you have to worry about the GLXINFO actually reporting correctly or even at all to graal4 wether or not you have updated drivers.
__________________
Daya (Developer)
Tįri Daya Mar Sana (Forest)
Queen of Forest
Reply With Quote
  #4  
Old 12-31-2006, 01:40 PM
Skyld Skyld is offline
Script-fu
Skyld's Avatar
Join Date: Jan 2002
Location: United Kingdom
Posts: 3,914
Skyld has much to be proud ofSkyld has much to be proud ofSkyld has much to be proud ofSkyld has much to be proud ofSkyld has much to be proud ofSkyld has much to be proud of
Send a message via AIM to Skyld
Quote:
Originally Posted by ReBorn_Spirit View Post
That Linux installer is horrible. First of all if your Environment isnt configured correctly it will cause errors.
That is because your environment is not configured correctly. I've used several Linux distributions with various configurations and it has worked fine.

What sort of errors are you getting?
Quote:
Originally Posted by ReBorn_Spirit
One of these common to find is trying to install graal4 onto a 64 bit Redhat based machine. The installer graal4 tries to install is 32 bit and doesn't match up to the FC 4 - 6 programs.
The Graal binary is 32-bit.

What do you mean not matching up to FC 4-6 programs? You mean libraries or?
Quote:
Originally Posted by ReBorn_Spirit
Then you have to worry about the GLXINFO actually reporting correctly or even at all to graal4 wether or not you have updated drivers.
Well, if your system is configured properly, this shouldn't be an issue. When I used Linux (various distributions), I always made sure that things like this worked when I was setting up the actual system, and never had any trouble with programs after that.
__________________
Skyld
Reply With Quote
  #5  
Old 12-31-2006, 10:39 PM
ReBorn_Spirit ReBorn_Spirit is offline
Tįri o Taurė
Join Date: Oct 2003
Location: North Dakota, USA
Posts: 1,060
ReBorn_Spirit is on a distinguished road
Quote:
Originally Posted by Skyld View Post
Well, if your system is configured properly, this shouldn't be an issue. When I used Linux (various distributions), I always made sure that things like this worked when I was setting up the actual system, and never had any trouble with programs after that.
With Fedora Core 5 and 6, the user doesn't have many options to missconfigure. So the only thing left for these people to do is install their drivers. I've seen problems with the nvidia drivers, but its never serious. Graal4 just won't read the glxinfo correctly on these computers with properly installed video drivers (NVIDIA). It's not really Graal's fault in general, it's just that its a newer version of linux that probably has its directories rearranged some so graal is just simply looking in the wrong place. Or GLXINFO might not have been installed properly.


As for above, the invalid liscense, I'd probably just unistall the game and reinstall it fresh. Sounds like it just won't patch itself.
__________________
Daya (Developer)
Tįri Daya Mar Sana (Forest)
Queen of Forest
Reply With Quote
  #6  
Old 01-01-2007, 02:56 AM
Questa Questa is offline
Back to the Beat
Join Date: Jan 2002
Location: USA
Posts: 1,230
Questa is on a distinguished road
Send a message via AIM to Questa
Quote:
Originally Posted by ReBorn_Spirit View Post


As for above, the invalid liscense, I'd probably just unistall the game and reinstall it fresh. Sounds like it just won't patch itself.
Oh I've done this many times; it just appears that the license files included with the latest version are bugged.
__________________
Reply With Quote
  #7  
Old 01-01-2007, 09:54 PM
Skyld Skyld is offline
Script-fu
Skyld's Avatar
Join Date: Jan 2002
Location: United Kingdom
Posts: 3,914
Skyld has much to be proud ofSkyld has much to be proud ofSkyld has much to be proud ofSkyld has much to be proud ofSkyld has much to be proud ofSkyld has much to be proud of
Send a message via AIM to Skyld
Quote:
Originally Posted by ReBorn_Spirit View Post
With Fedora Core 5 and 6, the user doesn't have many options to missconfigure. So the only thing left for these people to do is install their drivers. I've seen problems with the nvidia drivers, but its never serious. Graal4 just won't read the glxinfo correctly on these computers with properly installed video drivers (NVIDIA). It's not really Graal's fault in general, it's just that its a newer version of linux that probably has its directories rearranged some so graal is just simply looking in the wrong place. Or GLXINFO might not have been installed properly.


As for above, the invalid liscense, I'd probably just unistall the game and reinstall it fresh. Sounds like it just won't patch itself.
When installing the nvidia kernel module, you must make sure that the "glx" module is loaded in the X configuration file. A common mistake is that people don't load that module so therefore they don't get the full benefit of the drivers.

I am not sure that the directory structure has much to do with glxinfo; I should imagine it is prompting the graphics driver kernel modules directly for that information.
__________________
Skyld
Reply With Quote
  #8  
Old 01-02-2007, 12:41 AM
Admins Admins is offline
Graal Administration
Join Date: Jan 2000
Location: Admins
Posts: 11,693
Admins has much to be proud ofAdmins has much to be proud ofAdmins has much to be proud ofAdmins has much to be proud ofAdmins has much to be proud ofAdmins has much to be proud of
Quote:
Originally Posted by Questa View Post
Oh I've done this many times; it just appears that the license files included with the latest version are bugged.
The new version is working fine, tested it on several machines. I could imagine there could be problems when you have installed it as root before and try to install it as normal user now (or vice versa). Have you tried to uninstall and reinstall it?
Reply With Quote
  #9  
Old 01-02-2007, 01:27 AM
Questa Questa is offline
Back to the Beat
Join Date: Jan 2002
Location: USA
Posts: 1,230
Questa is on a distinguished road
Send a message via AIM to Questa
Quote:
Originally Posted by Stefan View Post
The new version is working fine, tested it on several machines. I could imagine there could be problems when you have installed it as root before and try to install it as normal user now (or vice versa). Have you tried to uninstall and reinstall it?
Yes. I've uninstalled, reinstalled in all of the combinations of user/root. It always gives me this error. I even deleted the licenses folder from my hard drive once, but that just gave me a license not found error.
__________________
Reply With Quote
  #10  
Old 01-08-2007, 05:54 AM
AbsoluteMonkey AbsoluteMonkey is offline
Registered User
AbsoluteMonkey's Avatar
Join Date: Oct 2006
Location: Boston, MA
Posts: 68
AbsoluteMonkey is on a distinguished road
Send a message via AIM to AbsoluteMonkey Send a message via MSN to AbsoluteMonkey Send a message via Yahoo to AbsoluteMonkey
I am having the same issue. I just did a clean install of Fedora Core 6 and tried to install Graal with the newest download from the site.
I get this output:
libGL warning: 3D driver claims to not support visual 0x4b
Direct Rendering is enabled, Graal should run smoothly.
Processor Init:
AMD (unknown)
FPU detected
MMX detected
3DNow detected
SSE detected

data directory: /usr/share/graal/
user data directory: /root/.graal/graal4/
The license file is invalid.
Reply With Quote
  #11  
Old 01-08-2007, 06:05 AM
AbsoluteMonkey AbsoluteMonkey is offline
Registered User
AbsoluteMonkey's Avatar
Join Date: Oct 2006
Location: Boston, MA
Posts: 68
AbsoluteMonkey is on a distinguished road
Send a message via AIM to AbsoluteMonkey Send a message via MSN to AbsoluteMonkey Send a message via Yahoo to AbsoluteMonkey
I just found another post that covered this issue.
]# graalexe
will run the game.
Reply With Quote
  #12  
Old 01-08-2007, 01:29 PM
Admins Admins is offline
Graal Administration
Join Date: Jan 2000
Location: Admins
Posts: 11,693
Admins has much to be proud ofAdmins has much to be proud ofAdmins has much to be proud ofAdmins has much to be proud ofAdmins has much to be proud ofAdmins has much to be proud of
Yes I have checked, starting "graalexe" is right. Did starting "graal" actually work before?
Reply With Quote
  #13  
Old 01-10-2007, 07:04 AM
AbsoluteMonkey AbsoluteMonkey is offline
Registered User
AbsoluteMonkey's Avatar
Join Date: Oct 2006
Location: Boston, MA
Posts: 68
AbsoluteMonkey is on a distinguished road
Send a message via AIM to AbsoluteMonkey Send a message via MSN to AbsoluteMonkey Send a message via Yahoo to AbsoluteMonkey
It used to work me. When I had the previous build from say..October. And FC5. But now I've done a fresh install of FC6 and installed the newest build on graal. Also the menu item that gets installed to run graal points to 'graal' and not 'graalexe'.
Now I'm getting a seg fault when I run graalexe. I'm thinking it's a vid card issue. I have a radeon 9200 with livna drivers installed. Any ideas?
Reply With Quote
  #14  
Old 01-10-2007, 08:06 AM
AbsoluteMonkey AbsoluteMonkey is offline
Registered User
AbsoluteMonkey's Avatar
Join Date: Oct 2006
Location: Boston, MA
Posts: 68
AbsoluteMonkey is on a distinguished road
Send a message via AIM to AbsoluteMonkey Send a message via MSN to AbsoluteMonkey Send a message via Yahoo to AbsoluteMonkey
Now I've noticed running '/usr/bin/graal' will get rid of the invalid license problem. But still I get seg fault. Is there a param that can be passed for the initial screen size. It seg faults after it tries to change the screen size.

]# /usr/bin/graal
Direct Rendering is enabled, Graal should run smoothly.
Processor Init:
AMD (unknown)
FPU detected
MMX detected
3DNow detected
SSE detected
data directory: /usr/share/graal/
user data directory: /root/.graal/graal4/
Scanning folder structure of /usr/share/graal/...
Done.
Activating the OpenGL display device (1)...
Setting screen mode to 640x480x32 (w)...
Segmentation fault
Reply With Quote
  #15  
Old 01-10-2007, 12:04 PM
Darklux Darklux is offline
Petrification of a Newbie
Darklux's Avatar
Join Date: Dec 2002
Location: Dortmund, Germany
Posts: 1,375
Darklux is a jewel in the roughDarklux is a jewel in the rough
Send a message via ICQ to Darklux Send a message via AIM to Darklux Send a message via Yahoo to Darklux
Iam on ubuntu feisty development unstable branch, and everything works fine and perfectly...

[email protected]:~$ uname -r
2.6.20-5-generic

Btw my hint for ubuntu users:
use Envy to get up to date nvidia drivers, its a small but really good python tool which gives you new drivers without your damaging your system, and up to date drivers are generally a good advice for people who also use their system for other things than officework.

Last edited by Darklux; 01-10-2007 at 06:04 PM..
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 05:47 PM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2022, vBulletin Solutions Inc.
Copyright (C) 1998-2019 Toonslab All Rights Reserved.