Graal Forums

Graal Forums (http://forums.graalonline.com/forums/index.php)
-   Bug Report (http://forums.graalonline.com/forums/forumdisplay.php?f=193)
-   -   Windows v6 beta test (http://forums.graalonline.com/forums/showthread.php?t=134257598)

Tigairius 01-01-2010 11:20 PM

Windows v6 beta test
 
6 Attachment(s)
Edit by Skyld:

I created this thread to keep a track of the bugs in the new Graal 6 client for Windows. I have moved posts from the Mac beta thread to this one. Please post any bugs or problems that you have here. Also consider checking if this bug has already been discussed in the Mac Beta Bugs thread, and make sure that you post the version of Windows that you are running, some information about your hardware and precisely how you replicate the error. I shall try and keep a track of bugs in this post.

__________________

Edit by Tig:

I will gray out anything that gets fixed, if something is fixed and it doesn't get grayed out, feel free to do it.
I will also collect some of the bug reports throughout this thread and post it on this main page.

__________________

Note to beta testers: Connect to "Login 2" to get the updated things (like updated profiles/playerlist). If you notice any bugs or have any suggestions for the profiles/playerlist please write them in here or forum PM me, suggestions about scripted-RC and other things (like Shared functions) would be best to contact Skyld.

__________________

Bugs in v6

+ If you copy something, you cannot copy something anymore, and you will only paste what you originally copied.


+ When calling "maximized = true" and "minimized = true" and such it is acting very strangely. Maximize doesn't maximize a window and minimize seems to destroy all the controls in the window and just decrease the size of the window to something really small.

+ canresize, canmove, canmaximize, etc don't work on external windows.

+ Movement becomes choppy "randomly" sometimes, and movement on attached objects is buggy (this happened after the added memory editing protection to the player.x/y/z in the most recent compiled version).

+ Tile layers support alpha blending (unlike v5) but now they don't support transparency.

+ If you mouse over something that doesn't have a hint, and you're currently looking at hints, the last hint you saw will still be displayed (see playerlist, hover over a player then move over to your "Buddies" tab or so).

+ onDblClick isn't invoked on a textlistctrl if there are multiple selections.

+ There is still some bug with showpolies being displayed 50 tiles south of where I intended them, but I'm unable to replicate it anywhere except my level editor (Tig/LLE on GK Debug -- you can test by pressing F4 and trying to select tiles on the level).
^ Update: Now it seems to be displaying about 3 tiles north of the correct place.

+ Functions like showtop() and makefirstresopnder(bool) are not working on external windows.

+ Windows open at mousex/mousey rather than what's defined in their script.

+ Emitters don't work with text.


+ When you have your mouse down and a new window pops up under your mouse, your mouseup event will never be invoked. Would be nice if it was doing some sort of object checking so it knew to invoke the event for mouseup.
For example, if you right click someone to open their profile, the "rightmousebutton" flag is still set to true, even after you close their profile, until you right-click again.

+ While you're walking and you press alt/ctrl or you click out of Graal, you will just continue walking even if you're not pressing the keys. The above suggestion could probably fix this.

^Update: Alt/ctrl is ok now, but if you click another window while walking you still continue walking.

+ Guitextlistctrls don't update unless they are active or you hover your mouse over them, for things like the playerlist this is not a good thing.

- should add some script commands (if not already added) to control a player's online status (like for plisticons: online,dnd,away,etc)

+ Login privileged scripts can't seem to read from the main graal folder anymore but they can write to the main graal folder.

+ External windows aren't calling events like onResize().

- Things like GuiPopUpMenuCtrls can support icons, but they only display in the drop-down list. As you can see here Attachment 50169 the icon displays, but in GS2, it doesn't: Attachment 50168 (even though the selected row has an icon). Reference to the playerlist on Login 2 for examples.

+ There are some problems with drawing on several controls (like scroll), you can see here that unless the scroll is clicked or scrolled, it cuts off the right side of the scroll:
Attachment 50171 How it should look: Attachment 50172
An example would be open your profile on Graal and just press enter a bunch of times in your "favourite quote" box, you'll notice that until you scroll the box or click the scroll, part of the scroll is chopped off.


+ There is also no task bar icon, it's just a blank 16x16 open spot: Attachment 50173
~ Reminder: Don't forget to pack the icons when you release the client.


+ Run command -listscriptfunctions is not working, it simply starts Graal normally. Actually, TSA reports that no run commands are working.


+ Certain bodies aren't displaying properly. (See: post 1 & post 2)

+ Syntaxhighlighting crashes the client.


+ Possible UDP problems? (See Rufus' post)

+ You can't walk and do an emoticon that is animated, only those that aren't.

+ When you drag external windows across the screen, it quits drawing the main Graal window. It would be nice if it continued to update other windows instead of doing this while you're dragging a window (Note: winXP and lower only):
Attachment 50188



Important Suggestions

* Suggestion: The "flickering" boolean, maybe it should also have something like "flickerimage" so we can define what is displayed in between flickers, and if flickerimage is not defined it could just show nothing. (This is needed for the playerlist).

* Suggestion: Some way to select multiple rows in a textlist, like setSelectedRows({0,1,2,3,4}); and setSelectedRowsByID({12,43,20,13,1}); This would be used for the playerlist.

* Suggestion: Some way to select text in a MLText ctrl.

* Suggestion: Some way to flash external windows when they're updated. On Mac the default behavior for this is to "pop" the window out on the dock, and certain linux distros also support the window flashing. Should look like this:
http://img64.imageshack.us/img64/8536/aimmsg.th.jpg

* Suggestion: Should update the client so .nw files also can specify if a tilelayer is blocking or non-blocking or using the tileset, and also if the tilelayer is drawoverplayer or drawunderplayer, etc. Also need to add some scripting variables to access this.

* Suggestion: In v6, you should check the integrity of default files like sword.gani, head0.png, sprites.png, etc so we don't have servers replacing them or so.

* Suggestion: Some sort of boolean for external windows to show always on top whenever the Graal client is the active application. Boolean could be something like GuiWindowCtrl.alwaysontop. (Will be used for the playerlist, PMs and Profiles).

Unimportant Suggestions

* Would be neat if string.substring(-1) cut off 1 character from the back of the string instead of having to do string.substring(0, string.length() - 1);

* Some level.zoom affect to scale the size of the level would be neat. I know many people had hoped this is possible. It would open a lot of possibilities for Graal, especially if it's also able to be done with tilelayers.

* Enabling timevar3 on regular servers.

Admins 01-06-2010 02:09 PM

Quote:

Originally Posted by Tigairius (Post 1548427)
-Guitextlistctrls don't update unless they are active or you hover your mouse over them, for things like the playerlist this is not a good thing.

You mean when you change the text of an entry?

Quote:

Originally Posted by Tigairius (Post 1548427)
- should add some script commands (if not already added) to control a player's online status (like for plisticons: online,dnd,away,etc)

There is TServerPlayer.playerlisticon, not sure if that helps.

Admins 01-06-2010 08:34 PM

Quote:

Originally Posted by Tigairius (Post 1548296)
- onDblClick isn't invoked on a textlistctrl if there are multiple selections.

Aren't double clicks selecting a single list entry anyway?

Admins 01-06-2010 09:05 PM

Quote:

Originally Posted by Tigairius (Post 1548296)
- If you mouse over something that doesn't have a hint, and you're currently looking at hints, the last hint you saw will still be displayed (see playerlist, hover over a player then move over to your "Buddies" tab or so).

Fixed.

Quote:

Originally Posted by Tigairius (Post 1548296)
- There is still some bug with showpolies being displayed 50 tiles south of where I intended them, but I'm unable to replicate it anywhere except my level editor (Tig/LLE on GK Debug -- you can test by pressing F4 and trying to select tiles on the level).

Fixed, was a problem with the menu moving the graal control offset.

Admins 01-07-2010 03:04 PM

2 Attachment(s)
Quote:

Originally Posted by Tigairius (Post 1548694)
- There is also no task bar icon, it's just a blank 16x16 open spot: http://forums.graalonline.com/forums...1&d=1262844424

Hmmm requires these images (in graal folder), someone remind me to package them with the next version:

Admins 01-07-2010 03:58 PM

Quote:

Originally Posted by Tigairius (Post 1548694)
- Things like GuiPopUpMenuCtrls can support icons, but they only display in the drop-down list. As you can see here http://forums.graalonline.com/forums...1&d=1262837586 the icon displays, but in GS2, it doesn't: http://forums.graalonline.com/forums...1&d=1262837576 (even though the selected row has an icon). Reference to the playerlist on Login 2 for examples.

Ok added icon display in GuiPopUpMenuCtrl.

Tigairius 01-07-2010 11:00 PM

Quote:

Originally Posted by Admins (Post 1548800)
Hmmm requires these images (in graal folder), someone remind me to package them with the next version:

Actually, would it be possible to control the icon via login-privileged scripts? Would be nice for the playerlist to show when you're getting a PM and stuff. Also an option to turn the icon off.

Skyld 01-09-2010 12:48 AM

Quote:

Originally Posted by Tigairius (Post 1548993)
Another thing I'd really like to see fixed would be this:

- When you drag external windows across the screen, it quits drawing the main Graal window. It would be nice if it continued to update other windows instead of doing this while you're dragging a window:

Very odd; I don't get this on Windows 7.

Riot 01-09-2010 01:53 AM

Quote:

Originally Posted by Skyld (Post 1549171)
Very odd; I don't get this on Windows 7.

I assume Tig is using Windows XP. In Windows Vista the window manager was changed and now caches the image a program displayed to prevent that exact issue from happening due to lock ups.

Stephen 01-09-2010 02:03 AM

Quote:

Originally Posted by Skyld (Post 1549171)
Very odd; I don't get this on Windows 7.

I also do not get this on Windows 7


- Player movement is rendered very choppy for some reason (cannot find the cause) but the canvas continues to render flawlessly.
- Cannot copy and paste multiple times, only once...
- movement on GMAP is not as nice as the initial beta released many months ago, it takes a long time to load the GMAP from an interior level and there is a short pause when the client loads the next level during movement.

Tigairius 01-09-2010 02:39 AM

Hmm.. Windows are still opening at mousex/y :(

Quote:

Originally Posted by zephirot (Post 1549186)
How to access the beta?

The Windows beta is not open yet, but more information will be posted soon.

Edit: Contact Skyld for information.

Rufus 01-09-2010 02:57 AM

I'm using a laptop which is running Windows 7, 32 bit. I haven't changed any settings, nor the program compatibility or anything like that.
  • When moving using the I, J, K, and L keys, if you hold down Ctrl or Alt and let go of your movement key, it will continue to walk in the direction that you were walking towards.

  • You can't walk and do an emoticon that is animated, only those that aren't.

  • The default "font height" on both the Graal 5 and Graal 6 clients is "24" but there is a notable difference in size. In addition to this, the text in the Graal 6 client isn't in bold like the other previous versions. [Graal 5] [Graal 6]

  • 'Special' characters that showed previously are now being replaced. [Graal 5] [Graal 6]

  • Maximizing to full screen messes up the screen. Ctrl, Alt and Delete and opening a program that disables visual themes also achieves this. These don't happen on my Graal 5 client, though a little error does pop up when I do Ctrl, Alt and Delete.

  • I use UDP (have the option unchecked) on the Graal 5 client, have my router forwarded correctly, and see people walking around fine. On the Graal 6 client I can't see anyone move who also uses UDP, even though I'm using the exact same settings.

TSAdmin 01-09-2010 03:05 AM

Quote:

Originally Posted by Skyld (Post 1549171)
Very odd; I don't get this on Windows 7.

Nor do I. That said, all bugs I report have occurred on Windows 7. Here are some things I do notice-

http://i50.tinypic.com/npq5bp_th.png
Click for larger image
-Some heads and bodies (Only seems to be on Classic servers, had no problems on Zone or GK) are not displaying at all. The heads aren't always a problem, but there are still some that don't show up. A lot of bodies don't show up at all though.

-Just a sidenote on this screenshot while it's up though, behind my "Movement chooser" GUI in the lower right, you'll notice that Era's displayed text for server alerts never disappears, just turns black. I'm figuring there's some support issues related to how Era displays it's messages specifically because it doesn't look to have any problem with showtext();

http://i50.tinypic.com/5yavzm_th.png
Click for larger image
-Trying to edit in Client RC causes the client to not respond, and inevitably crash once you click a script to edit.

http://i47.tinypic.com/27wx1xg_th.png
Click for larger image
-No matter what setting you choose for "Run:" in the Graal's shortcut properties, it will open in "Normal window" but with the attribute chosen enabled anyway. EG: I set my Graal shortcut to "Run Maximized", but opening it the game doesn't open maximised at all, however the "Maximize" button is still visually changed to "Restore Down".


This is not the bug in action, but on Kingdoms when you hold down left, right and down, it is almost identical to the bug.
-Okay, I am not entirely sure what causes this one specifically but after the client's been running for some time, I've noticed that switching from one window to another then back to the Game client seems to give slow movement feedback to the client to respond.
For example, once the bug kicks in, I cant move diagonally (Doesn't allow two buttons at once to be pressed, the new button cancels the first), and when I do move the feeling is as if it is moving 1 tile every 0.05 seconds with a sharp pause giving instead of a solid __________ feel like you see in my video, it gives a ---------- feel with cuts in the movement, jolts if you will.

If you get "An error occurred. Please try again later. it may not be "Live" just yet.

-No screenshot for this one since it happens only randomly, but it was also a bug in v5 that seems to have continued over to v6, and I'm sure most of you have probably seen it before. The player's head in the minimap occasionally changes to a randomly selected other online player's head image.

That's all I have for now that I gathered since I started testing.

DustyPorViva 01-09-2010 03:09 AM

Is the body problem the typical bug where changing the color values of the gani makes them disappear until they move? Or are files missing or some such?

cbk1994 01-09-2010 03:09 AM

Quote:

Originally Posted by Rufus (Post 1549198)
  • The default "font height" on both the Graal 5 and Graal 6 clients is "24" but there is a notable difference in size. In addition to this, the text in the Graal 6 client isn't in bold like the other previous versions. [Graal 5] [Graal 6]
  • 'Special' characters that showed previously are now being replaced. [Graal 5] [Graal 6]

These are both probably a result of using a different font rendering engine (same one Mac/Linux uses). Both of these things have been happening on Mac since I've been using it, and Stefan mentioned he was switching how fonts were rendered in the new version of Windows as well.

Rufus 01-09-2010 03:17 AM

  • File download: guigames_arcmessage2.png not found. Had a whole bunch of other "guigames" files not downloading too.

Quote:

Originally Posted by TSAdmin (Post 1549201)
-Just a sidenote on this screenshot while it's up though, behind my "Movement chooser" GUI in the lower right, you'll notice that Era's displayed text for server alerts never disappears, just turns black. I'm figuring there's some support issues related to how Era displays it's messages specifically because it doesn't look to have any problem with showtext();

Possibly related: In Graal 6 the (custom) state GUI on Bomy Island sets the "A S D" text to black. If I close the start bar however, the problem fixes and the text is white again. [Before] [After]

Quote:

Originally Posted by cbk1994 (Post 1549203)
These are both probably a result of using a different font rendering engine (same one Mac/Linux uses). Both of these things have been happening on Mac since I've been using it, and Stefan mentioned he was switching how fonts were rendered in the new version of Windows as well.

I wouldn't mind if they looked the same as what they have always looked like.

TSAdmin 01-09-2010 03:20 AM

Quote:

Originally Posted by DustyPorViva (Post 1549202)
Is the body problem the typical bug where changing the color values of the gani makes them disappear until they move? Or are files missing or some such?

Files are not missing and it happens even when you setbody to a body that is affected by this bug. Moving doesn't do anything either. You're a floating head basically. Changing from a body that does display to a body that doesn't though, the part of the image displayed when you did setbody to an affected body to denote the direction you were facing sticks, so if I were facing left with body1.png, then setbody to an affected body, whether I move left, right, up down, pull, push, anything the body I was previously wearing is displayed stuck in the left position until I set my body to an unaffected file.

http://i50.tinypic.com/16bkkjm.png

Admins 01-09-2010 03:22 AM

Quote:

Originally Posted by Rufus (Post 1549206)
  • File download: guigames_arcmessage2.png not found. Had a whole bunch of other "guigames" files not downloading too.

Delete your FILENAMECACHE.txt.

Quote:

Originally Posted by Rufus (Post 1549206)
I wouldn't mind if they looked the same as what they have always looked like.

It's a complete new rendering engine, it's now using the same font rendering as on Mac and Linux (which has also been changed slightly) so it can't possibly look exaclty the same.

DustyPorViva 01-09-2010 03:24 AM

Quote:

Originally Posted by Admins (Post 1549208)
Delete your FILENAMECACHE.txt.


It's a complete new rendering engine, it's now using the same font rendering as on Mac and Linux (which has also been changed slightly) so it can't possibly look exaclty the same.

But can't you make it display in bold like the older versions?

cbk1994 01-09-2010 03:28 AM

2 Attachment(s)
Quote:

Originally Posted by TSAdmin (Post 1549207)
Files are not missing and it happens even when you setbody to a body that is affected by this bug. Moving doesn't do anything either. You're a floating head basically. Changing from a body that does display to a body that doesn't though, the part of the image displayed when you did setbody to an affected body to denote the direction you were facing sticks, so if I were facing left with body1.png, then setbody to an affected body, whether I move left, right, up down, pull, push, anything the body I was previously wearing is displayed stuck in the left position until I set my body to an unaffected file.

http://i50.tinypic.com/16bkkjm.png

This (or a similar thing) happens on the Mac client as well, for example with "era_tachi-newsuit1.png" (attached) on Era.
Attachment 50197

Tigairius 01-09-2010 03:35 AM

Quote:

Originally Posted by Admins (Post 1548652)
Aren't double clicks selecting a single list entry anyway?

Currently, on native windows you can hold shift on a textlist and select many things and double click when you're done to open a mass message, so onDblClick() should also work with multiple selections.

Edit: I see what you mean though, when DblClick is invoked with multiple selections, just make it send the last entry the player clicked.


Quote:

Originally Posted by Admins (Post 1548610)
You mean when you change the text of an entry?

Yes, or an entry is added/removed.

TSAdmin 01-09-2010 03:48 AM

Quote:

Originally Posted by TSAdmin (Post 1549201)

This is not the bug in action, but on Kingdoms when you hold down left, right and down, it is almost identical to the bug.
-Okay, I am not entirely sure what causes this one specifically but after the client's been running for some time, I've noticed that switching from one window to another then back to the Game client seems to give slow movement feedback to the client to respond.
For example, once the bug kicks in, I cant move diagonally (Doesn't allow two buttons at once to be pressed, the new button cancels the first), and when I do move the feeling is as if it is moving 1 tile every 0.05 seconds with a sharp pause giving instead of a solid __________ feel like you see in my video, it gives a ---------- feel with cuts in the movement, jolts if you will.

If you get "An error occurred. Please try again later. it may not be "Live" just yet.

Okay, I managed to replicate the glitch by using multiple "ALT + KEY" combinations and sometimes holding them both down (Not sure if it's just ALT + Key, or if it's just any two keys held down too long).



Notice how the first set of seconds its like I'm moving, stopping, moving, stopping like the -------- explanation I used earlier, then the last few (After pausing video, closing and reopening a new instance of Graal) I am moving smoothly like ____________

Rufus 01-09-2010 04:20 AM

Playerlist:
  • When a member of staff sends out a mass message on tag, their PM bubble is just blue like a regular mass. Only the bubble that is on the top of the playerlist tab displays red.
  • When a player or member of staff sends a message/guild message, their heads are hidden when the bubble 'animation' is playing. Shouldn't their heads show when the PM bubble isn't flashing, instead of it just being blank?
  • Players who you select to PM go to the top of the list of players and it doesn't seem right.
  • There is a pretty large delay (a good 30 seconds) in the playerlist displaying guild tags once set. This also applies for moving the person into the guild tab, and for those who are unsetting their tags.
  • People who have removed their guild tags still remain in the guild list.
Profiles:
  • Profile labels are being cut because of the input boxes.
  • The "Favorite Quote" part of the profile isn't wrapping.
Other:
  • I have to be unpaused to open the Options window using F3.
  • F5 still brings up the Load Level window, but is this still used?

fowlplay4 01-09-2010 04:22 AM

Quote:

Originally Posted by Rufus (Post 1549221)
[*]F5 still brings up the Load Level window, but is this still used?

Something like this should only open for Staff imo.

cbk1994 01-09-2010 04:25 AM

Quote:

Originally Posted by Rufus (Post 1549221)
  • When a member of staff sends out a mass message on tag, their PM bubble is just blue like a regular mass. Only the bubble that is on the top of the playerlist tab displays red.

Is this really a bad thing?

Rufus 01-09-2010 04:27 AM

Quote:

Originally Posted by cbk1994 (Post 1549223)
Is this really a bad thing?

Yes? It's inconsistent with the tab icon that is shown, staff messages have been red since I can remember, and they serve as a distinction between an admin message and a regular mass.

Stephen 01-09-2010 04:29 AM

Quote:

Originally Posted by Rufus (Post 1549224)
Yes? It's inconsistent with the tab icon that is shown, staff messages have been red since I can remember, and they serve as a distinction between an admin message and a regular mass.

Yea, I agree. I pointed this out in the last beta as well. >_<

Deas_Voice 01-09-2010 04:30 AM

Quote:

Originally Posted by TSAdmin (Post 1549201)
Nor do I. That said, all bugs I report have occurred on Windows 7. Here are some things I do notice-

http://i50.tinypic.com/npq5bp_th.png
Click for larger image
-Some heads and bodies (Only seems to be on Classic servers, had no problems on Zone or GK) are not displaying at all. The heads aren't always a problem, but there are still some that don't show up. A lot of bodies don't show up at all though.

that totally happens on linux(none beta) client too.
it seems to only happen with the default body system...

Rufus 01-09-2010 04:33 AM

  • Nicknames that are enlarged through script become quite blurred. [Example]

cbk1994 01-09-2010 04:47 AM

Quote:

Originally Posted by Rufus (Post 1549224)
Yes? It's inconsistent with the tab icon that is shown, staff messages have been red since I can remember, and they serve as a distinction between an admin message and a regular mass.

For private messages, sure, but the fact that it's under the "Staff" heading seems a fair enough indication to me that's it's from a staff member :p.

It's annoying when on Windows because there's no way of distinguishing between a mass message and a personal message.

TSAdmin 01-09-2010 05:00 AM

-"Full screen resolution" option in F3 doesn't save your choice anymore. Other F3 options seem to change and retain fine.

Rufus 01-09-2010 05:06 AM

  • When moving (on all defined movement controls) if you Alt and Tab out of the window your character won't stop moving in the direction you were heading in. Much like the Ctrl/Alt bug I mentioned earlier with IJKL movement.

DustyPorViva 01-09-2010 05:38 AM

Quote:

Originally Posted by fowlplay4 (Post 1549222)
Something like this should only open for Staff imo.

I sometimes use it to copy/paste the level name I'm in... though such a thing could probably be better implemented by servers themselves as staff tools than a window that is pretty much otherwise useless.

TSAdmin 01-09-2010 05:48 AM

On the note of character's not being read properly, I notice this in the Game Messages & Engine Log:

Quote:

Couldn't open C:Windowsfonts empsitc.ttf for writing!
File download: head983.gif (size: 3978) done
File download: microsoft sans serif.ttf not found
File download: idle.gani (size: 7988) done
File download: segoe uibd.ttf not found
File download: segoe ui.ttf not found
File download: tempsitcbd.ttf not found
File download: ariali.ttf not found
File download: arialit.ttf not found
Notice the first entry, it doesn't have any backslashes, so it's not finding the path to the fonts folder by the looks of it.

Tigairius 01-09-2010 06:38 AM

Quote:

Originally Posted by Rufus (Post 1549221)
Playerlist:
  • When a member of staff sends out a mass message on tag, their PM bubble is just blue like a regular mass. Only the bubble that is on the top of the playerlist tab displays red.
  • When a player or member of staff sends a message/guild message, their heads are hidden when the bubble 'animation' is playing. Shouldn't their heads show when the PM bubble isn't flashing, instead of it just being blank?
  • Players who you select to PM go to the top of the list of players and it doesn't seem right.

I'll try to fix these soon. The second one is actually a problem stefan may have to fix with the "flickering" boolean.

Quote:

Originally Posted by Rufus (Post 1549221)
  • There is a pretty large delay (a good 30 seconds) in the playerlist displaying guild tags once set. This also applies for moving the person into the guild tab, and for those who are unsetting their tags.
  • People who have removed their guild tags still remain in the guild list.

Alright, I have improved the time it takes to update but it should never have been 30 seconds, the timer was on 2 seconds. Perhaps you mean that the playerlist wasn't updating but that's a bug that's already on the main page (guitextlistctrls not updating).

Quote:

Originally Posted by Rufus (Post 1549221)
Profiles:
  • Profile labels are being cut because of the input boxes.
  • The "Favorite Quote" part of the profile isn't wrapping.

Are you sure you're using the profile system from "Login 2"? I remember fixing both of those things.

Make sure you're using the profile and playerlist system from Login 2.

TSAdmin 01-09-2010 07:47 AM

Hmm, not sure if this is fixed with your login2 stuff or not, Tig. I've mostly been using the login2, but just noticed one thing without them:

-F2 messages (sendRPGMessage(); ) do not update unless the F2 window is already open. Noticed this while levelling on GK and using /skills

Tigairius 01-09-2010 08:07 AM

Quote:

Originally Posted by TSAdmin (Post 1549246)
Hmm, not sure if this is fixed with your login2 stuff or not, Tig. I've mostly been using the login2, but just noticed one thing without them:

-F2 messages (sendRPGMessage(); ) do not update unless the F2 window is already open. Noticed this while levelling on GK and using /skills

Yes, I've noticed that too, I think the problem with that is that it's not logging messages unless you open it at least once (then you can close it again and experience no problems). Maybe I can get that fixed.

Tigairius 01-09-2010 08:12 AM

Quote:

Originally Posted by Rufus (Post 1549221)
Playerlist:
  • When a member of staff sends out a mass message on tag, their PM bubble is just blue like a regular mass. Only the bubble that is on the top of the playerlist tab displays red.
  • Players who you select to PM go to the top of the list of players and it doesn't seem right.

These are fixed now (on Login 2 only).

TSAdmin 01-09-2010 10:44 AM

I noticed something on GK with the boats where the script is trying to update the players location in relation to the boat but it doesn't seem to be working in v6. Perhaps there's a slight downfall in support for this. As with 90% of my bug reports, here's a short video to show you the bug in action:


As usual, if you get An error occurred. Please try again later, check back again after 5 or so minutes. The video may not be "Live" yet.
Also, sorry about the MSN and Trillian sounds in the background!

Shadow5596321 01-09-2010 11:53 AM

All I see is the captain wanting his booty. Yes, I really just did that.


All times are GMT +2. The time now is 09:33 PM.

Powered by vBulletin® Version 3.8.3
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
Copyright (C) 1998-2008 Linux cyberjoueurs All Rights Reserved.