PDA

View Full Version : Vista and Lag.


Misoneism
12-28-2007, 09:35 PM
I've had this problem, since I got my new computer, and was forcefully upgraded to Vista. Searching through old topics and posts has shown no results to help my problem.
Basically once I log into graal, and pop on a server with more then about 5 people, everything starts to lag, if I'm in a level by myself, it runs perfectly fine. The lag is pretty much related to the number of players im near, but the thing is this never happened on my old XP computer, I even loaded up my XP laptop, and It ran fine.

It happends on every server, but only occurs when numerous players are near.
My Comp Spec are as follows
CPU: AMD Athalon x2 Dual Core 2.20 GHz
RAM: 3.5 Gb RAM
Video Card: NVidia GeForce 6150SE
OS: 32-Bit Vista Home (Premium I beleive)


I have 'Fixed Port for UDP' checked atm,
and 'Don't use UDP for data packages' unchecked,
I have tried combinations of unchecked and checked for either of these
and Nothing seems to fix the problem.

In the Task Manager, upon starting graal it begins sitting at around 57K doesnt move much.

And game_console is below.

Scanning folder structure of C:/Users/MiZZo/Graal/...
Done.
Created DirectDraw object
Initialized Direct3D7
Initialized DirectDraw
CPU: 32 bit
Graphic Capabilities:
Hardware accelerated graphics: true
Video Memory: 1592 Mbyte
Drawing of alpha blended textures: true
Textures with non-power-of-2 size: true
3D Textures with non-power-of-2 size: true
2D during 3D scene: true
Use 32 bit alpha: true
Initialized Direct3D7
Graal has been activated!
Loading tile definitions for server Login
Connecting to the game server...
Done.
Loading tile definitions for server Login
Connecting to the game server...
Done.

Anything else needed to seek a cure to this ailment, I will supply.

Cloven
12-28-2007, 11:48 PM
I've had this problem, since I got my new computer, and was forcefully upgraded to Vista. Searching through old topics and posts has shown no results to help my problem.
Basically once I log into graal, and pop on a server with more then about 5 people, everything starts to lag, if I'm in a level by myself, it runs perfectly fine. The lag is pretty much related to the number of players im near, but the thing is this never happened on my old XP computer, I even loaded up my XP laptop, and It ran fine.

It happends on every server, but only occurs when numerous players are near.
My Comp Spec are as follows
CPU: AMD Athalon x2 Dual Core 2.20 GHz
RAM: 3.5 Gb RAM
Video Card: NVidia GeForce 6150SE
OS: 32-Bit Vista Home (Premium I beleive)


I have 'Fixed Port for UDP' checked atm,
and 'Don't use UDP for data packages' unchecked,
I have tried combinations of unchecked and checked for either of these
and Nothing seems to fix the problem.

In the Task Manager, upon starting graal it begins sitting at around 57K doesnt move much.

And game_console is below.

Scanning folder structure of C:/Users/MiZZo/Graal/...
Done.
Created DirectDraw object
Initialized Direct3D7
Initialized DirectDraw
CPU: 32 bit
Graphic Capabilities:
Hardware accelerated graphics: true
Video Memory: 1592 Mbyte
Drawing of alpha blended textures: true
Textures with non-power-of-2 size: true
3D Textures with non-power-of-2 size: true
2D during 3D scene: true
Use 32 bit alpha: true
Initialized Direct3D7
Graal has been activated!
Loading tile definitions for server Login
Connecting to the game server...
Done.
Loading tile definitions for server Login
Connecting to the game server...
Done.

Anything else needed to seek a cure to this ailment, I will supply.

Press F3, and uncheck 'use bitmap fonts' in Video options. For some reason, on Vista 32bit, having that box checked actually creates a world of lag for most people. You can also try unchecking all of the boxes as well, if you're not picky about certain things.

And I say this having a more updated pc than you have and an 11-17ms ping.

cbk1994
12-29-2007, 02:40 AM
Get a mac, MiZZo

Misoneism
12-29-2007, 05:28 AM
Press F3, and uncheck 'use bitmap fonts' in Video options. For some reason, on Vista 32bit, having that box checked actually creates a world of lag for most people. You can also try unchecking all of the boxes as well, if you're not picky about certain things.

And I say this having a more updated pc than you have and an 11-17ms ping.

Wow, thank you so much... This actually helped, which is extremely odd
because in the options it proclaims it's "Faster and smoother".
This alongside 'use minimum video resources' made everything run at a faster rate.

There is still some lag, in more heavily populated areas, which is somewhat annoying but the above took away the lag from common places, OSL and such.

Cloven
12-29-2007, 08:48 AM
Wow, thank you so much... This actually helped, which is extremely odd
because in the options it proclaims it's "Faster and smoother".
This alongside 'use minimum video resources' made everything run at a faster rate.

There is still some lag, in more heavily populated areas, which is somewhat annoying but the above took away the lag from common places, OSL and such.

Glad to see it helped some. :D

cbk1994
12-29-2007, 04:29 PM
Wow, thank you so much... This actually helped, which is extremely odd
because in the options it proclaims it's "Faster and smoother".
This alongside 'use minimum video resources' made everything run at a faster rate.

There is still some lag, in more heavily populated areas, which is somewhat annoying but the above took away the lag from common places, OSL and such.

My advice was better :(