PDA

View Full Version : Onwall2 Linux vs Windows


Projectshifter
05-29-2006, 01:35 AM
I was working on a movement system, and I was using clientsided Onwall2 to detect the walls. I'm on the Linux client, and it works fine for me, but then someone else is on Windows and they get different points detecting onwall than I do. For example if we're both pushing on a wall, my X is different than theirs. I switched to Windows and my X is still slightly different than some, but not the same when I'm on Linux. I think there is a problem with different systems detecting onwall2 slightly differently. The script uses the same x/y comparisons so it isn't different per user, it's constant. I switched to using onwall and everyone gets the same coordinates then.

Admins
05-29-2006, 02:10 AM
It should be the same, both use the same underlying engine. Do you have npcs with weird shape? Would be interesting if it's may be special images which are behaving differently.

KuJi
05-29-2006, 03:12 AM
It should be the same, both use the same underlying engine. Do you have npcs with weird shape? Would be interesting if it's may be special images which are behaving differently.

We are testing it on tiled walls (straight down the level)

You can come check it out if you want ;P.

Click Here (graal://graal x)

Projectshifter
05-29-2006, 04:21 AM
Also, Linux Graal has thing thing with question marks on my system. I'll be typing a PM, and i'll hit a question mark, it'll keep repeating for a while until I hit question mark and **** again. It's not a repeating error on my system either.

Skyld
05-30-2006, 10:19 AM
I found myself walking into a tree. Well, okay. I found myself walking through a tree before hitting an imaginary block. Is this what you mean?

If so, then it's happening in the Mac version too.

KuJi
05-31-2006, 04:46 AM
I found myself walking into a tree. Well, okay. I found myself walking through a tree before hitting an imaginary block. Is this what you mean?

If so, then it's happening in the Mac version too.

No, it's not. Zero Hour updated the gfx of the tree. I forgot to fix setshape2 :p

Admins
06-02-2006, 07:47 PM
Also, Linux Graal has thing thing with question marks on my system. I'll be typing a PM, and i'll hit a question mark, it'll keep repeating for a while until I hit question mark and **** again. It's not a repeating error on my system either.

I have experienced the same problem, when pressing Shift+another key and then releasing shift then the other key is not stopping. It's a bug of SDL, will need to replace SDL with direct X11 calls.

KuJi
06-02-2006, 09:05 PM
I have experienced the same problem, when pressing Shift+another key and then releasing shift then the other key is not stopping. It's a bug of SDL, will need to replace SDL with direct X11 calls.

Something like this happens on Windows. Say I am on Era playing w/ my bher spinning, if I get imed while holding F it like auto's F. (IMed via Aim :p )

Stefan, can you log on sometime and help PS w/ this movement sys btw :p