PDA

View Full Version : "Don't Block" not working


Curt1zzle
02-18-2005, 03:39 AM
Any script that has "dontblock" or possibly "drawoverplayer" / "drawunerplayer" will not work on the Mac client.

I'm not sure about the specific scripts, since I can't view them, but the blocks on the NPulse spar arena won't let me in and neither will the unstick me guard on Valikorlia that makes you say "I Agree".

Please fix if at all posible :)

Ajira
02-18-2005, 05:09 AM
I believe it's some error with the transparency. For me, images that are normally transparent on v2 are not transparent on v3. For example, the blocks to the UN spars. =/

Curt1zzle
02-18-2005, 07:28 AM
I believe it's some error with the transparency. For me, images that are normally transparent on v2 are not transparent on v3. For example, the blocks to the UN spars. =/

Ah yes, I've noticed that. Perhaps that is the problem.

Common things like shields bodies and heads aren't working correctly as well.... :\

Doahh_p2p
02-18-2005, 05:27 PM
Gralats and my heads

Admins
02-19-2005, 01:01 AM
Give me a level name (and server name) where you have problems with npcs

Curt1zzle
02-19-2005, 02:46 AM
Level: npspar.nw

Server: N-Pulse

Problem: The two block.png images (That block the entrance to the sparring pit) won't ever move out of the way for me to enter the spar, works for everyone but me..

----

Level: onlinestartlocal.nw

Server: Valikorlia

Problem: The guard who is blocking the main door doesn't move when you say "I Agree" like he is suppposed to. Works for everyone but me...

Admins
02-23-2005, 05:24 PM
Ok fixed some bugs:

- Modifying the board[] in v3.1 was not working, fixed it, so it will work in the next release of v3.1. This was bugging the spar level on npulse, but someone should fix those ****ty scripts anways, they are sending 12 tiles 20 times each second to the server, instead of just using an npc that is hiding/unhiding (eventually using setshape to make it more secure). Because of sending those tiles to the server it is probably also lagging the spar.

- Found the bug in v3.1 that was sometimes not hurting other people (or not letting other people hurt you): it was checking if the guild name is equal, and if both players have an empty guild name then it was thinking they are in the same guild and not allowing them to hurt each other, will be fixed in the next v3.1 release

- On Valikorlia they were using "playersays" which is not supported for 4 years now and will also be removed from v2.3 in the next release. I have replaced "playersays(text)" with "playerchats && strequals(#c,text)", so their scripts should work correctly now (some of those playersays where used on serverside where it is not supported anyway, wondering why no one noticed that they don't work).

Ok some more bugs fixed in v3.1:
- when a gani attribute has been changed to a gani (#Px, #P(index)) then the showimgs from the last gani were not removed, causing e.g. the hitpoint bar on Graal Kingdoms to become red if you first hit a monster (displaying "- 15 hp" in red) and then get hurt by the monster (displaying 2 showimgs for the hitpoint bar). Will be fixed in the next release

- in the new scripting engine on clientside #L and #F were wrong, on clientside #L must be the player level and #F the npc level (on serverside #L is the npc level and #F is the player level). In combination with another bug which showed the npc level as empty when you are attached to an object, the map and other things were not working on ships on Graal Kingdoms Debug.