PDA

View Full Version : Graal on Mac - Crashes on Start


Trevor
07-22-2004, 05:53 AM
I just bought a new Apple Powerbook 12" (http://www.apple.com/powerbook/index12.html) computer. After a couple days of playing on I decided I'd give Graal a try on it. As you probably already know, it isn't working.

The error is fatal. I do not even get a display window. Graal just shuts down and OS X gives me a error window, asking me to submit the error to Apple. I opted out of that thinking it would hardly do me any good. I figured I might get a faster response if I posted here. :]

Anyways, here is my `console.log' file:
//-------------------------- 7/21/2004 -- 22:42:03 -----

System & Processor Information:

MacOS version: 10.3.4

CarbonLib version: 1.6.0

Physical RAM: 512MB

Logical RAM: 2047MB

Unknown/PowerPC G4u ++, 1333 Mhz

FPU detected

AltiVec detected




Math Init:

Installing Standard C extensions

Installing FPU extensions



Input Init:

Basic mouse capture failed to enable!



Video Init:

Accelerated OpenGL display device detected.



applicationdir: /Applications/Graal/

--------- Loading MODS ---------



Engine initialized...



--------- Initializing MOD: Common ---------

Activating the OpenGL display device...

Activating the OpenGL display device...

Cleaning up the display device...
I highlighed the part that I think is stating the fatal error.

calum
07-22-2004, 02:44 PM
I think it might be to do with OpenGL...

Trevor
07-22-2004, 05:46 PM
I don't think so, because if you look at this part of the log message I provided:
Video Init:

Accelerated OpenGL display device detected.
You will notice it detects that my device is OpenGL ready. I guess it could be some kind of OpenGL mouse failure, however.

I'm waiting for Stefan to give me some adive on what to do, as I think he is that only one who can really help me.

haro41
07-23-2004, 03:31 AM
yes same with me, i couldnt log onto UN at all without it crashing on loadup, as well as many other playerworlds. And it is just terrible over all. i suggest you scrap V3 all together.

Trevor
07-23-2004, 03:42 AM
Not using v3 is not a viable option for me. I have two computers; one running Gentoo Linux, while the other is, as you know, running Mac OS X 10.3.4.

Also, you don't seem to be getting the same error as I. While I can not even get a window to open at all, you just can not connect to certain servers.

Lance
07-23-2004, 03:48 AM
The setup unexpectedly quits on my friend's mac. No idea...:(

TSonicWarp9
08-13-2004, 11:29 PM
I'm no Mac expert.

Did you try any sort of updates for your graphics handlers and OS updates? Try to apply all updates you find for your OS and then try again, or get a Windows programs Emulator and use the Win32 version until someone can come up with an answer to the problem.

Don't be stressed, they still haven't found a way to get Graal to funtion correctly on visuals on Mandrake Linux.

Malinko
08-13-2004, 11:37 PM
I remember talking to Stefan once about Linux+Windows, but no one seems to care much for the Mac side of Graal >_>. No clue what to do though.

TSonicWarp9
08-13-2004, 11:40 PM
I remember talking to Stefan once about Linux+Windows, but no one seems to care much for the Mac side of Graal >_>. No clue what to do though.


*in a sarcastic tone* Geeee! I wonder why...

I'm sure there is someone who can run Graal on this spacific machine, try to find them to see how they solved the problem.